Click2Shell Flaw in WordPress Core Enables Remote Code Execution via Single Malicious Link

Researchers at pwn.ai have disclosed Click2Shell, a vulnerability in the WordPress core that allows an attacker to install a malicious theme and achieve remote code execution simply by tricking an authenticated administrator into opening a crafted link. The isolated flaw carries a CVSS score of 7.1, but the full attack chain reaches 9.6. The issue stems from an interpretation mismatch between the WordPress.org theme directory and the administrator browser, causing the browser to automatically trigger the install button without any user confirmation or password prompt. Affected versions start from 6.0 and run up to but not including 7.1.1. The vulnerability has been fixed in WordPress 7.1.1 with backported patches released for all supported branches down to version 4.7. No exploitation in the wild had been observed at the time of disclosure, yet the low barrier of convincing an admin to click a link makes prompt patching essential.

BoletimSecTranslated from Portuguese

Read at source

Researchers from pwn.ai have disclosed a critical flaw in the WordPress core, dubbed Click2Shell, that lets an attacker install a malicious theme and reach remote code execution with nothing more than a single link sent to an authenticated administrator.

The vulnerability received an isolated CVSS score of 7.1, but the complete attack chain that leads to code execution scores 9.6. Importantly, the issue resides in the WordPress core itself rather than any third-party plugin.

Versions from 6.0 through releases prior to 7.1.1 are affected. The attack exploits a divergence in how the WordPress.org theme directory and the administrator’s browser interpret the same URL parameter. The directory treats the value as a normal theme name, while the browser re-uses the original text inside code that locates an element on the page, causing the browser to automatically activate the install button.

No manual click on the install button, no password prompt, and no confirmation dialog are presented to the victim. The only prerequisite is that an authenticated administrator must open the malicious link; without an active admin session the attack cannot complete.

The fix is included in WordPress 7.1.1. Equivalent patches have also been released for all still-supported branches, extending back to the 4.7 release line. A CVE identifier is expected to be assigned shortly.

At the time of publication, researchers had not observed any exploitation of the flaw in real-world attacks. Because successful exploitation depends solely on convincing an administrator to visit a URL, organizations are advised to apply the update without waiting for confirmed incidents.

Meridian digestThe week's most consequential security stories, distilled into one briefing.See the digest

More in Vulnerabilities & Exploits

Telegram for Android Patches Voice Call Vulnerability Enabling Code Execution
Yandex Patches Millions of Stations After eMudhra Certificate Keys Compromised
Cisco ASA and FTD Face DoS Vulnerability in SSL VPN Already Exploited in the Wild