LibreOffice and Apache OpenOffice Flaws Enable Remote Code Execution via Malicious Spreadsheets Without Macro Warnings

Two vulnerabilities, CVE-2026-63277 in LibreOffice Calc and CVE-2026-59265 in Apache OpenOffice, allow attackers to execute arbitrary code simply by tricking users into opening specially crafted spreadsheet files. The flaws exploit Java integration and class path handling, bypassing traditional macro security prompts entirely. LibreOffice has already released fixes in versions 26.2.5 and 26.8.0 that restrict class path entries to local file URLs only. Apache OpenOffice 4.1.16 and earlier remain vulnerable, with the stable patch expected in 4.1.17; interim mitigation requires disabling Java integration. The issues highlight risks in office suites that process untrusted documents containing external data connections or JDBC references. Organizations are advised to enforce least-privilege execution and avoid opening files from unknown sources until patches are applied.

HispasecTranslated from Spanish

Read at source

Two vulnerabilities allow attackers to execute arbitrary code simply by opening manipulated office documents, bypassing the usual macro security warnings. The flaws affect LibreOffice Calc and Apache OpenOffice through their integration with Java and the way these applications resolve certain components when loading untrusted files.

CVE-2026-63277 impacts LibreOffice and permits a crafted spreadsheet to trigger loading of a Java database driver from a remote location. The root cause lies in class path handling: an attacker-controlled entry can point outside the local system, causing the application to fetch and execute classes from an external source. The fix enforces that every class path entry must be a file-type URL, effectively blocking remote class loading.

Users should update LibreOffice to version 26.2.5 or 26.8.0 or later. These releases also harden handling of external data links and JDBC connectors in Calc, reducing exposure in environments that regularly exchange spreadsheets containing database connections.

CVE-2026-59265 affects Apache OpenOffice 4.1.16 and earlier, enabling local or remote code execution when a malicious document abuses the Java integration. A stable patch is planned for 4.1.17, currently available only as a release candidate. Until then, administrators should disable Java support in OpenOffice wherever it is not strictly required.

Additional defensive steps include limiting Java usage across office suites on endpoints that frequently open attachments, enforcing strict policies against opening files from untrusted origins, and applying application isolation where feasible. Running office applications with the lowest possible privileges further contains any successful exploitation to the user’s permission boundary.

Meridian digestThe week's most consequential security stories, distilled into one briefing.See the digest

More in Vulnerabilities & Exploits

Telegram for Android Patches Voice Call Vulnerability Enabling Code Execution
Yandex Patches Millions of Stations After eMudhra Certificate Keys Compromised
Cisco ASA and FTD Face DoS Vulnerability in SSL VPN Already Exploited in the Wild