Critical GitLab Flaw CVE-2026-110264 Allows Unauthenticated Remote Code Execution

GitLab has released patches for a maximum-severity vulnerability that permits unauthenticated remote code execution on self-managed installations. The flaw, tracked as CVE-2026-110264 with a CVSS score of 10.0, stems from an integer overflow during regular expression compilation. It affects every version starting from 7.0 released in 2014 and impacts both Community and Enterprise editions. The issue was reported through the company's HackerOne bug bounty program and has no available workaround. Patches are available in multiple recent releases, though earlier critical updates from October 12 do not cover this vulnerability. No exploitation has been observed as of October 22, and the flaw is not yet listed in the NVD or CISA's exploited vulnerabilities catalog.

BoletimSecTranslated from Portuguese

Read at source

GitLab has published fixes for a critical vulnerability that enables remote code execution without authentication on self-managed instances. The flaw, identified as CVE-2026-110264, received the maximum CVSS 10.0 score and currently has no available mitigation.

The root cause is an integer overflow in the regular expression compiler. A specially crafted expression causes the compiler to overflow, which under certain conditions leads to arbitrary code execution on the server. The attack can be launched over the network with no credentials and requires no user interaction.

The vulnerability affects all versions from 7.0 (released in 2014) onward in both the Community and Enterprise editions. Fixed releases include 19.5.1, 19.4.3, 19.3.6, 19.2.9, 19.1.9, 19.0.10, and 18.11.13. Organizations that applied the October 12 critical update remain unprotected, as that package only addressed the earlier CVE-2026-97229 (also CVSS 10.0) and covered versions 19.2 and later.

GitLab.com is already running the patched version. Tenants of GitLab Dedicated starting from 19.3.5-internal0 and 19.4.2-internal0 have received the update. Self-managed deployments require database migrations that will cause downtime on single-node instances.

The update bundle contains 12 CVEs in total. The critical issue was reported by researcher joaxcar through the company's HackerOne bug bounty program. Offensive security firms such as HackerSec treat maximum-severity flaws in CI/CD servers as high priority because these systems often store cloud credentials and sign production artifacts.

As of October 22, no exploitation attempts have been reported. The vulnerability does not yet appear in the NVD or CISA's list of actively exploited vulnerabilities. GitLab has published two detection rules focused on regex compiler crashes and repeated markup rendering errors for organizations unable to patch immediately.

Meridian digestThe week's most consequential security stories, distilled into one briefing.See the digest

More in Vulnerabilities & Exploits

Telegram for Android Patches Voice Call Vulnerability Enabling Code Execution
Yandex Patches Millions of Stations After eMudhra Certificate Keys Compromised
Cisco ASA and FTD Face DoS Vulnerability in SSL VPN Already Exploited in the Wild